Add-on Updater 19.01 disponible en français

Jeudi 20 Décembre 2018

Coucou mes amis du blog de BlindHelp!
Dans les dernières heures, le module complémentaire Add-on Updater
Il est mis à jour vers la version 19.01, dans laquelle la capacité de réponse est améliorée et des avancées techniques sont réalisées pour la future transition du code NVDA vers Python version 3.
Il est important de noter que cette nouvelle version est uniquement compatible avec NVDA 2018.4 et versions ultérieures (c’est-à-dire, les versions de test Alpha de 2019.1).

Quelques informations utiles données par son auteur Joseph Lee

Quelques points à noter:

  • Même s’il s’agit désormais d’un module complémentaire stable, le Add-on Updater est toujours étiqueté comme preuve de concept. Une fois que la mise à jour du module complémentaire est livrée à NVDA, le Add-on Updater sera abandonné.
  • Tous les modules complémentaires que vous avez obtenus ne seront pas mis à jour. Pour le moment, seuls les modules complémentaires répertoriés sur le site Web comunautaire des modules complémentaires NVDA (addons.nvda-project.org), ainsi que le Remote Support add-on, pourront faire l’objet de vérifications de mise à jour par le Add-on Updater.
  • Vous pouvez demander à NVDA de ne jamais vérifier les mises à jour des modules complémentaires à la base par module complémentaire, ainsi que demander à NVDA de rechercher les snapshots en développement.
  • Si vous désactivez un module complémentaire, le Add-on Updater ne recherchera pas de mises à jour pour ces modules complémentaires. Si vous désactivez le Add-on Updater, vous ne pourrez pas rechercher les mises à jour des modules complémentaires via NVDA. Plusieurs modules complémentaires sont fournis avec leur propre fonction autonome de vérification de mise à jour. Si cette option est désactivée, ces fonctions de vérification des mises à jour autonomes seront activées (à moins que vous ne désactiviez cette option à partir des modules complementaires eux-mêmes).

Exigences:

  • NVDA 2018.4 ou ultérieure
  • Windows 7 Service Pack 1 ou ultérieur

Module complémentaire sur la page principale du site comunautaire des modules complémentaires NVDA:

Code source sur GitHub:

Pour les personnes souhaitant fournir des pull requests: n’hésitez pas à fournir des pull requests pour des problèmes (issues), excepté: demander des vérifications de mise à jour pour des modules complémentaires non hébergés sur le site comunautaire des modules complémentaires. Si vous le demandez dans votre pull request (ou en tant qu’une nouvelle incidence (issue) pour ce module complémentaire), en particulier si vous ajoutez des packages provenant d’un site Web donné (oui, je suis sûr que vous connaissez le site dont je parle), je ‘ Je les ferme sans commentaire. Cette restriction concerne principalement le contrôle de la qualité.
Profitez donc.
Amitiés,
Joseph

Merci à son auteur Joseph Lee pour cette information très importante.


Add-on Updater sur la page principale du site comunautaire des modules complémentaires NVDA:
Télécharger version stable

Add-on Updater peut être mis à jour de forme autonome, afin que vous puissiez suivre le processus de vérification habituel pour le mettre à jour. Quoi qu’il en soit, si cela ne fonctionne pas ou si vous ne disposez toujours pas de ce module complementaire vous pouvez le télécharger à partir du lien ci-dessus.

Si une ancienne version de ce module complémentaire était déjà installée, sa mise à jour est aussi simple que d’aller dans le menu NVDA, Outils, Check for add-on updates (traduit par Rechercher les mises à jour des modules complémentaires. Sinon, il peut être téléchargé manuellement à partir du lien ci-dessus.

Maintenant l’interface de ce module complémentaire est entièrement traduit en français, merci à Michel Such pour son temps et son dévouement.😉

Voilà donc, tout est dit au sujet de la nouvelle mise à jour de Add-on Updater 19.01 disponible en français!
Je vous souhaite une bonne installation!
Bien amicalement,
Rémy (BlindHelp).


Nous espérons vous revoir bientôt sur le
Blog de BlindHelp!
ou sur votre nouveau espace via GitHub:
BlindHelp.github.io